CIS 221 Lab 6 Configuring and Managing Printers


Lab 6 Configuring and Managing Printers
For this lab students will have to establish network connection. Do the following to establish the connection.
This lab contains the following exercises and activities:

· Exercise 6-1: Installing a Shared Printer

· Exercise 6-2: Accessing Shared Printers

· Exercise 6-3: Configuring Web Printing

· Exercise 6-4: Managing Documents in the Print Queue

· Exercise 6-5: Printer PermissionsScenario
Like nearly all large businesses, Contoso, Ltd., has many printers. As a technical support agent, you are often required to handle printer-related issues, including the following:

· Installing printers

· Configuring printers

· Managing print queues

· Sharing printers

The company has just purchased several new printers that you will be asked to configure according to the needs of various users within Contoso.
After completing this lab, you will be able to:

· Install and access shared printers.

· Configure and use Internet printing.

· Manage documents in a print queue.

· Set printer permissions.

Before You Begin

There are no prerequisites to Lab 6.

This lab uses the variable xx to refer to your number, so that your computer name is referred to as Computerxx and your student identity as Studentxx. You are asked to pair with another student in this lab. Your partner's number is referred to as yy.

Establish your network connection using the following steps.

1. Log on as local Administrator.

2. From the Start menu right click on My Computer and select Properties

3. From the Computer Name tab click on Change.

4. In the Computer Name Change dialog box erase .local from the Domain box.

5. Click OK

6. In the Computer Name Chang dialog box in User name type Administrator and in the Password box type none.

7. Click OK

8. After a few seconds you will be welcomed to the Contoso domain click OK.

9. Click on the dialog box that tells you that you must restart your computer.

10. Click OK in the Systems Properties dialog box.

11. Click Yes in the Systems Setting Change dialog box, you computer will shut down and restart.

12. Log on as local administrator.

13. From the start menu select Control Panle

14. Select Security Center

15. Open the Windows Firewall and make sure that it is Off.
16. Close all windows.
Exercise 6-1: Installing A Shared Printer

Contoso has purchased some new printers that you need to install on a print server. One of the printers has a built-in network interface card (NIC) and will communicate to the server using the TCP/IP protocol at Internet Protocol (IP) address 10.10.10.45.

Installing a Shared Printer

The following steps will install a printer and share it on the network.

1. Log on with your local Administrator credentials.

2. From the Start menu, select Printers And Faxes.

3. In the Printers And Faxes window, in the Printer Tasks pane on the left, select Add A Printer.

4. In the Add Printer Wizard, on the Welcome page, click Next. 

5. On the Local Or Network Printer page, ensure that Local Printer Attached To This Computer is selected and clear the Automatically Detect And Install My Plug And Play Printer check box. Click Next.

6. On the Select A Printer Port page, in the Use The Following Port drop-down list, select FILE: (Print To File) 
7. Click Next.

Note: Although adding printers that print to file can be useful, it is more common to add a USB port, or a TCP/IP port to print to a print device. because of the limitations of the lab environment, we are printing to file only as a simulation of printing to a print device.

8. On the Install Printer Software page, in the Manufacturer list box, select Generic.

9. In the Printers list box, select Generic / Text Only and then click Next.

10. In Use Existing Drivers page make sure that Keep existing drivers is selected click Next
11. On the Name Your Printer page, in the Printer Name text box, type Printer1 and then click Next.

12. On the Printer Sharing page, ensure that Share Name is selected
13. Accept the default name of Printer1 Click Next.

14. On the Location And Comment page, in the Location text box, type Room xx.

15. In the Comment text box, type Prints text only documents to C:\Documents and Settings\User and then click Next.

16. On the Print Test Page page, ensure that Yes is selected and then click Next.

17. On the Completing the Add Printer Wizard page, click Finish.

18. In the Print To File message box, in the Output File Name text box, type Test.txt and then click OK.

19. A Printer1 message box appears. 
Note ; At this point, you might want to click Troubleshoot to become familiar with the Printing Troubleshooter in the Help And Support Center, but it is not required for the lab. Other-wise, 
20. Click OK.

21. Close the Printers And Faxes window.

22. From the Start menu, select My Computer.

23. Browse to C:\Documents and Settings\Administrator.

24. Open the Test.txt file.

 Question 1: Using the Text.txt file and fill in the following table
	Computer Name
	

	Printer name
	

	Port name
	

	Data format
	

	Location
	

	Driver name
	

	Driver version
	


Upload the test.txt file to D2L (10 points)
25. Close all open windows.

Installing a Printer Using a TCP/IP Port

The following steps will install a printer to TCP/IP port using address 10.10.10.45

1. From the Start menu, select Printers And Faxes.

2. In the Printers And Faxes window, in the Printer Tasks pane, click Add A Printer.

3. In the Welcome To The Add Printer Wizard, on the Welcome page, click Next.

4. On the Local Or Network Printer page, ensure that Local Printer Attached To This Computer is selected, and that the Automatically Detect And Install My Plug And Play Printer check box is cleared. Click Next.

Note: The Microsoft Windows XP interface on this task is confusing. To install a printer using TCP/IP that is using a network interface card to connect to the network, you select Local Printer Attached To This Computer, even though the print device (physical printer) is no more local to your computer than any other computer on the network, nor is it directly attached to your computer. But the printer (logical printer) is local to your computer, which is why you choose Local Printer Attached To This Computer. 

5. On the Select A Printer Port page, select Create A New Port, and in the drop-down list, select Standard TCP/IP Port and then click Next.

6. In the Add Standard TCP/IP Printer Port Wizard, on the Welcome page, click Next.

7. On the Add Port page, in the Printer Name Or IP Address text box, type 10.10.10.45.

Warning: Windows XP automatically creates a port name of IP_ followed by the IP address. However, this name should not be confused with the actual IP address of the port, because while you can later change the IP address of the port, Windows will not allow you to rename the port. This results in a port name that does not represent the actual port.

8. Accept the default port name of IP_10.10.10.45 by clicking Next.

9. On the Additional Port Information Required page, click Next to accept the default settings.

Note: The Additional Port Information Required page will not appear in most cases when a printer is attached to the network at the specified IP address, because Windows will usually be able to connect to the printer via TCP/IP.

10. On the Completing The Add Standard TCP/IP Port Wizard Page, click Finish.

11. On the Install Printer Software page, in the Manufacturer list box, select HP. 
12. In the Printers list box, select HP LaserJet 4100 Series PLC and then click Next.

13. On the Name Your Printer page, click Next to accept the default settings.

14. On the Printer Sharing page, select Share Name, and in the text box, type Printer2. Click Next.

15. On the Location And Comment page, in the Location text box, type ICT 223 and then click Next.

16. On the Print Test Page page, select Yes and then click Next.

17. On the Completing The Add Printer Wizard page, click Finish.

18. Collect you test page (the one with your computer name on it) write your name on it and turn it in.

19. Log off.
Exercise 6-2: Accessing Shared Printers

A user requires access to a printer attached to a computer in the room next door but does not know how to connect to it. You need to connect to the printer for him over the network.

Accessing a Shared Printer through the Network

The following steps will connect to the printer by browsing to it through the network.

1. Log on to Contoso with your student account. (The password is P@sswOrd.)

2. From the Start menu, select My Computer.

3. In My Computer, in the Other Places pane, click My Network Places.

4. In My Network Places, in the navigation pane, under Other Places, click Entire Network.

5. In the Entire Network window, double-click Microsoft Widows Network.

6. In the Microsoft Windows Network window, double-click Contoso.

Wait until your partner has completed the previous step before continuing.

7. In the Contoso window, double-click Computeryy.

8. In the Computeryy window, double-click Printer1.

9. In the Printer1 On Computeryy window, from the Printer menu, select Properties.

10. In the Printer1 On Computeryy Properties dialog box, in the General tab, click Print Test Page.

11. In the Print To File dialog box, in the Output File Name text box, type Printed From Computerxx.txt and then click OK.

12. In the Printer1 On Computeryy message box, click OK.

13. In the Printer1 On Computeryy Properties dialog box, click OK.

14. Close the Printer1 On Computeryy window.

15. In the \\Computerxx window, in the address text box, type C:\Documents And Settings\Studentxx.CONTOSO and press ENTER. 
Question 2:  When you print to file on a shared printer on another computer, by default, is the document printed to a file on the local computer or on the computer hosting the printer?

16. Log off.

Searching for a Printer in Active Directory 
You are on an on-site service call within Contoso and need to print some diagnos¬tic information, but there is no printer attached to the computer. There are several printers located in the room next to you (Room yy), but you do not know if any of them are available on the domain. You therefore need to search for printers according to location to see if there are any printers in Room yy available to you.

1. Log on with your local Administrator account.

2. From the Start menu, select Printers And Faxes.

3. In the Printers And Faxes window, right-click Printer1 and then select Rename.

4. For the name, type Printer3 and then press ENTER.

5. Log off and log on to Contoso with your student account.

6. From the Start menu, select Search.

7. In the Search Results window, in the Search Companion pane, under What Do You Want To Search For, click Printers, Computers, Or People.
8. In the Find Printers dialog box select Contoso in the drop down box for the In window 
9. On the Features tab Select the Can Print Color check box, and then click Find Now. 

Question 3: How many printers at Contoso are available that can print color?

10. Clear the Can Print Color check box.

Wait until your partner has completed the previous step before continuing.

11. In the Printers tab, in the Location text box, type Room yy and then click Find Now.

Question 4: What printer is available in Room yy?

12. Close the Find Printers dialog box and the Search Results window.

Using the Add Printer Wizard to Add a Network Printer

You are setting up a workstation within the advertising department and need to install a network printer on the workstation.

1. From the Start menu, select Printers And Faxes
2. In the Printers And Faxes window, in the Printer Tasks pane on the left, select Add A Printer
3. In the Add Printer Wizard, on the Welcome page, click Next.

4. On the Local Or Network Printer page, answer the following question
Question 5: What is the only option available to your student account on Contoso, and why are the other options unavailable?

5. Click Next.
6. On the Specify A Printer page, ensure that Find A Printer In The Directory is selected, and then click Next.

7. In the Find Printers dialog box, select Contoso in the dropdown list for the In box

8. Click Find Now.

9. In the search results pane, select Printer3 in Room yy and then click OK.

10. On the Default Printer page, select No and then click Next.

11. On the Completing The Add Printer Wizard page, click Finish.
12. Close all windows.
13. Log off.

Exercise 6-3: Configuring Web Printing
To make printer administration and access more convenient for the technicians at Contoso, you want to configure Internet printing. This will allow access to the print servers via a Web browser. The technicians have wireless access on their Pocket PCs to the intranet, so when Internet printing is configured, they will be able to manage print servers anywhere on the Contoso campus with their Pocket PCs.

 Copying Installation Information from the CD to the Hard Disk
In this Exercise you will copy the installation files from the Windows XP Professional CD to the Hard drive of the Computer.
Caution:  You are making changes to the registry of the Operating System.  If you make a mistake you could cause the OS to stop functioning.  Ask questions if you are not sure of a step.

1. Sign on as the local administrator
2. Place the Windows XP installation disk in the CD/DVD drive and cancel all installation windows that appear.

3. Open Windows Explorer 
4. In the Windows Explorer window click on New(D:)
5. Right-click on the I386 folder and select Copy
6. In the Windows Explorer window click on Local Disk(C:)
7. Right-click on the right window and click on paste (the process of pasting may take up to 5 minutes).
8. Remove the Windows XP installation disk for the CD/DVD drive.
9. From the start click on Run and type Regedit.

10. In the Edit menu click on Find
11. In the find box type sourcepath and click Find next.

12. Press F3 twice until you find Service pack sourcepath.

13. Right-click on ServicePathSourcePack and select modify.

14. Change the value in the box to C:\ and hit OK.

15. Right-click on ServicePath (next entry)and select modify.

16. Change the value in the box to C:\ and hit OK. When you complete these two changes the entries should look like the image below.
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17. Close the Registery Editor.
Configuring IIS for Internet Printing

The following steps will install Internet Information Services (IIS) and Internet printing.


1. From the Start menu, select Control Panel.
2. In Control Panel, click Add Or Remove Programs.

3. In the Add Or Remove Programs window, in the navigation pane, click Add/Remove Windows Components.

4. In the Windows Components Wizard, on the Windows Components page, select Internet Information Services (IIS) (but do not select the check box next to it), Click Details.

5. In the Internet Information Services (IIS) dialog box, select World Wide Web Service (but do not select its check box), and then click Details.

6. In the World Wide Web Service dialog box, select the Printer Virtual Directory check box, and then click OK.

Note:  When you select the Printer Virtual Directory check box, the Windows Components Wizard automatically selects several other check boxes for components on which the Printer Virtual Directory component is dependent, or which are necessary for configuring TCP/IP. These components are World Wide Web Services, Internet Information Services Snap-In, and Common Files. 

7. In the Internet Information Services (IIS) dialog box, click OK.

8. In the Windows Components Wizard, click Next.

9. The Configuring Components page will appear, which will indicate installation progress.

10. On the Completing the Windows Components Wizard page, click Finish.

11. Close all windows and Restart your computer.
Important:  Windows does not indicate that it is necessary to restart at this point, but the next task will fail unless you so. Even if Windows does not request a restart, it is good practice to restart after installing or removing system components.
Accessing Network Printers Through a Web Browser

The following steps will allow you to connect to the printer installed on your partner's computer via a Web browser.

1. Log on to Contoso with your student account.

2. From the Start menu, select Internet Explorer.

Wait until your partner has completed the previous step before continuing.

3. In Internet Explorer, in the Address text box, type http://Computeryy/ Printers and then press ENTER.

4. The All Printers On Computeryy page will appear.
Question 6: What printers are found on Computeryy and what is there status?
.
5. Leave Internet Explorer open for the next task.
Exercise 6-4: Managing Documents In The Print Queue
1. In Internet Explorer, in the Address text box, type http://localhost/ printers and then press ENTER.

Note: Localhost is an alias for the If address 127.0.0.1, which is called the loopback address. The loopback address is an address that always points back to the local computer. Thus, localhost can be used as a placeholder to connect to the local machine using Internet Protocol (IP').
2. On the AllPrinters On Localhost page, click HP Laser 4100 series PCL.

3. On the HP Laser 4100 series PCL On Localhost page, under Printer Actions, click Pause.

4. In the Connect To Computerxx.Contoso.Local dialog box, in the User Name text box, type Administrator, and in the Password text box, type P@sswOrd. Click OK.

5. The HP Laser 4100 series PCL On Localhost page will update and the Printer Queue designation will change to Paused
Question 7: Fill in the following table from the information displayed

	Printer Model
	

	Location 
	

	Network Name
	

	Documents
	

	Speed
	

	Color
	

	Print on both sides
	

	Max Resolution
	


6. Close Internet Explorer.

7. Right-click your desktop, point to New, and then select Text Document.

8. Name the document How To File For Chapter 11.txt
9. Double-click How To File For Chapter 11.txt
10. Type This is document 1 on Computer xx
11. From the File menu click on Save.
12. From the File menu select print, 

13. In the Print dialog box, select HP Laser 4100 series PCL and then click Print
14. From the File menu select save as, rename the file War and Peace and click Save.

15. In the War and Peace document and type This is document 2 on Computer xx and save the document.
16. From the File menu select print
17. In the Print dialog box, select HP Laser 4100 series PCL and then click Print
18. From the File menu select save as, rename the file Internet Jokes and click Save.

19. In the Internet Jokes document and type This is document 3 on Computer xx and save the document.
20. From the File menu select print
21. In the Print dialog box, select HP Laser 4100 series PCL and then click Print
22. Close Microsoft word.

23. In the Notification area, double-click the Printer icon.

Question 8: What is the order of the document in the print window and why?
Canceling Documents

The following steps will cancel the documents in the print queue.

1. In Internet Explorer, in the Address text box, type http://localhost/ printers and then press ENTER
2. In Internet Explorer, on the HP LaserJet 4 On Localhost page, click Document List.

3. Under Printer Actions, click Cancel All Documents.
4. In the Connect To Computerxx.Contoso.Local dialog box, in the User Name text box, type Administrator, and in the Password text box, type P@sswOrd. Click OK
5. Close all open windows. 
Exercise 6-5: Printer Permissions
1. Log off and log back on with your local Administrator credentials.

2. From the Start menu, select Printers And Faxes.

3. In the Printers And Faxes window, right-click HP Laser 4100 series PCL and then click Properties.

4. In the HP Laser 4100 series PCL Properties dialog box, in the Security tab, click Add.

5. In the Select Users, Computers, Or Groups dialog box, in the Enter The Object Names To Select (Examples) text box, type Contoso\Studentxx and then click Check Names.

6. In the Enter Network Password dialog box, in the User Name text box, type Administrator, and in the Password text box, type none. Click OK.

Question 9: You are currently logged on as an administrator. Why can't you use your current credentials to add your student account?
7. Select the first entry in the list that appears and click OK
8. The Select Users, Computers, Or Groups dialog box should update showing the addition of Student07 {studentxx@conteso.local} Click OK.

9. In the HP LaserJet 4 Properties dialog box, ensure that Studentxx is selected. 
Question 10: What permissions are allowed? 
10. In the Permissions For Studentxx list box, select the Allow check box for the Manage Documents permission.

11. Click OK.
12. Close all windows and shut down computer
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